Relay DHCP in virtual routing



  • Hi,

    How to configure a DHCP relay in a instance routing type virtual router?

    I have no problem with the default VR, but the default VR is type forwarding.

    Thanks,



  • I have such config on my SRX240 and in HA … (dhcp-server in one virtual-router, dhcp-request from another virtual-router, forwarding-option in top level configured only (in virtual-router no effect), I use 10.4r3.4)

    forwarding-options {
      packet-capture {
          file filename DebugTraffic size 500k world-readable;
          maximum-capture-size 1500;
      }
      helpers {
          traceoptions {
              file DebugForwardingInet0 size 200k files 3;
              level all;
              flag bootp;
              flag util;
          }
          bootp {
              relay-agent-option;
              server IP.ADD.RESS routing-instance virtual-router-vr;
              maximum-hop-count 10;
              minimum-wait-time 1;
              client-response-ttl 64;
              interface {
                  reth1.234;
              }
          }
      }
    }

    security zone security-zone some-zone-with-dhcp-request {
    interfaces {
      reth1.234 {
          host-inbound-traffic {
              system-services {
                  dhcp;
                  bootp;
              }
          }
      }
    }

    (you have to see traffic, if is all right …)
    show system services dhcp relay-statistics
    node0:

    Received packets: 539
    Forwarded packets: 539
    Dropped packets: 0
      Due to missing interface in relay database: 0
      Due to missing matching routing instance: 0
      Due to an error during packet read: 0
      Due to an error during packet send: 0
      Due to invalid server address: 0
      Due to missing valid local address: 0
      Due to missing route to server/client: 0



  • Great – I’ve been waiting for an solution for a long time. could you please post a sample of your config?? Thanks!



  • My last known report is … dhcp relay working between virtual-routers … the only things you need to make … (default!) forwarding-options helpers bootp … and then on interface assign dhcp and bootp … in context "security zone security-zone host-inbound-traffic system-services"
    Works, there is no problem 😉



  • When I tried to make config according “old” netscreen on SRX, I have got dhcp-relay via 1 routing-instance and within 1 virtual-router working …

    Then I changed config into from 1 virtual-router to 2nd virtual-router … and nothing works … Junos 10.4r3.4 … still not supported?



  • Not supported.


 

31
Online

38.4k
Users

12.7k
Topics

44.5k
Posts