SSG-5 slow SQL Program via VPN



  • Hello All

    bear with me because I am new to Juniper hardware, I have been experiencing an issue with a SQL program which I would like to use over the VPN link. I have created a VPN in the SSG-5 router using the Corelan guide . The VPN link works fine for all other connections e.g. rdp, filesharing or transfers. The issue is when I use this SQL program on the remote client it takes forever to update fields the Windows 7 round circle just spins for 2-5 secs each time I click on a new field within the program, I also experiencing a similar issue with active directory users and computers across the VPN. I have tested this this particular software across other VPN and its find a little slower the lan, but other than that it’s fine. I have also talked to the developer and they tell me that there should not be any issues with the software across a VPN.

    There is more than enough bandwidth on both the remote client and the VPN for the SQL program.

    The connection latency is <50ms

    I have ran a debug on the SSG-5  and didn’t find anything that was useful (may of missed something)

    DNS resolution is working correctly.

    I’ve also tried

    unset flow tcp-syn-check
    unset flow tcp-syn-bit-check

    Please Help any ideas would be great seem to of hit a wall.

    regards

    John



  • The issue was the poorly writing SQL program only workaround was to access it via RDS



  • I’ve disable sql alg and no luck, haven’t tried win xp yet.



  • hard to tell. it may be due to the SQL alg, but i dont think so. you can disable it using “unset alg sql” or something like this (check with “get alg”). tried windows xp? win 7 does a lot of confusing stuff like mtu discovery and so on. it prefers ipv6 over ipv4, too, while ipv6 is always enabled.



  • my config

    SSG-5.txt


 

44
Online

38.4k
Users

12.7k
Topics

44.5k
Posts