SCP: Admin user 'netscreen' requested unknown file '– /ns_sys_config'.



  • Hi,

    I just realised that my backup script is not working. Well, in addition to adding error codes I now wonder how to solve this:

    I tried to backup the config of the device (running ScreenOS 6.2.0r7.0) like this:

    scp -i ns netscreen@192.168.1.1:/ns_sys_config backup.cfg

    But the device gives me the following error:
    SCP: Admin user ‘netscreen’ requested unknown file ‘– /ns_sys_config’.

    Although “get file” clearly shows, that the file is still there and called the same.

    Any ideas?



  • This issue seems to be solved in 6.2.0r11. It is mentioned in the release notes:

    585314— SCP to the firewall failed from an UNIX machine and displayed the error “unknown file '–ns_sys_config.”



  • This is now listed in the release notes as a known issue in 6.2.0r10. I guess r7 is affected as well

    Maybe you already opened a JTAC case and this is the reason.

    Hopefully this will be fixed in the next release.

    Have you actually tried r8 and r9?



  • Thats the way I did my backups, too (Debian at home)

    NS-> get ssh
    SSH V2 is active
    SSH is enabled
    SSH is ready for connections
    Maximum sessions: 3
    Active sessions: 1

    Admin      Ip Addr        Vsys      Auth Method  Service
    –-------- --------------- ---------- ------------ --------
    —      192.168.1.--    Root      password    console
    NS-> get scp
    SCP is enabled
    SCP is ready
    NS->



  • your’re welcome  😄

    That is really strange cause that’s the way we are backing up our devices once a day. Never had issues with that… (standard redhat installation)

    … maybe sth. with the ssh version (since 5.1 v2 is default)

    what is the output of “get ssh” and “get scp”



  • Hey,
    thanks for the ultra fast reply. You are right with Putty. It works if I use “pscp -scp” but the Linux SSH/SCP does not work. That is damn strange! But thank you for the workaround!!



  • I just tried this on a lab device which is running the same screenos version. With pscp I had to force the proto scp and it is only working without the / in front of the config file:

    pscp.exe -scp netscreen@192.168.1.1:ns_sys_config backup.cfg

    With the slash I got an error message

    pscp version i used: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html


 

30
Online

38.4k
Users

12.7k
Topics

44.5k
Posts