Srx pap authentication



  • Hello everyone 🙂

    i have a cisco config this is poin-to-point adsl and it gets an ip address by negotiation.
    i did config on srx but always i get at

    at-1/0/0                up    up 
    at-1/0/0.0              up    down inet

    i can not get an ip address what is wrong with my config ? Below there is cisco and srx configs.
    Thank you very much….

    CISCO CONFIG
    !       
    interface ATM0
    mtu 1500
    no ip address
    no atm ilmi-keepalive
    pvc 8/35
      pppoe-client dial-pool-number 1
    !
    interface Dialer0
    ip address negotiated
    ip mtu 1400
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp pap sent-username xxxxx@xxxxx password 7 06575D72181B5F4E
    !

    SRX CONFIG
    root# show | display set
    set version 11.1R2.3
    set system root-authentication encrypted-password "$1$OlNU1iDT$b.oU15Y3iGSWM1km/P6fO1"
    set system syslog file sinan any info
    set interfaces at-1/0/0 encapsulation atm-pvc
    set interfaces at-1/0/0 atm-options vpi 8
    set interfaces at-1/0/0 dsl-options operating-mode auto
    set interfaces at-1/0/0 unit 0 encapsulation atm-ppp-vc-mux
    set interfaces at-1/0/0 unit 0 vci 8.35
    set interfaces at-1/0/0 unit 0 ppp-options pap access-profile deneme
    set interfaces at-1/0/0 unit 0 family inet negotiate-address
    set access profile deneme client “xxxxx@xxxxx” pap-password "$9$4naDiqmfzn/.mIESrvMDiH"
    set access-profile deneme



  • Hi,

    Had the same issue trying to connect to BT 20CN ADSL (PPPoA):

    1. As mentionned: Don’t use access-profile, code user and pwd in ppp-option.
    2. Not a Cisco expert but it looks like your Cisco is configured for PPPoE while your SRX config is PPPoA
    3. Check which version of code you are using, on SRX110 I had authentication working but never managed to get address negotiation on 11.4, downgrading to 11.2r6.3 magically solved the problem (didn’t change one line of config, just downgraded and rebooted and it worked) - so obviously some regression bug there.

    Check with show interface at-1/0/0 detail if your PAP/CHAP authentication is up or not and if the issue is at IPCP negotiation stage

    Good luck.



  • Hi there

    I had the same problems setting up an ADSL connection here in the UK so the settings will be slightly different.  However I got it to work by not using an access profile and using local-name instead.

    (We use chap)

    set……ppp-options chap default-chap-secret "password"
    set…ppp-options chap local-name "login@isp.co.uk"
    set…passive

    Good luck, this drove me crazy but now it’s rock solid

    Adam



  • Hi,

    you config looks the same as mine, the error unfortunately too -> I’m having the same issue. Please HELP!


 

34
Online

38.5k
Users

12.7k
Topics

44.5k
Posts