SRX/JunOS 11.4 : activating load balacing between two ISP



  • Hello all,

    I’m using an SRX100 with a simple configuration :
    -fe-0/0/0.0 is my LAN interface (192.168.88.8/24)
    -fe-0/0/1.0 is for Wifi (192.168.33.10/24)
    -fe-0/0/6.0 is ISP 1, connected on a modem using DHCP (assigned IP is my public IP, 88.188.0.5)
    -fe-0/0/7.0 is ISP 2, connected to another ADSL modem,  using PPPoE to establish connection (interface pp0.0).

    on my routing-options static, I can have :
    route 0.0.0.0/0 next-hop pp0.0
    I have full internet access using ISP 2
    route 0.0.0.0/0 next-hop 88.188.0.254 (which is the gateway to use for ISP1)
    I have full internet access using ISP 1

    but if I try to have
    route 0.0.0.0/0 next-hop [ 88.188.0.254, pp0.0 ]
    nothing works.

    Looking at https://www.juniper.net/techpubs/en_US/junos12.2/topics/concept/routing-policy-security-ecmp-flow-based-forwarding-understanding.html I have correctly set the two interfaces (pp0.0 and fe-0/0/6.0) to the same security zone. Also the load-balancing-policy is set to load-balance per-packet
    policy-statement load-balancing-policy {
    then {
    load-balance per-packet;
    }
    }
    and also
    user@host# show routing-options
    forwarding-table {
    export load-balancing-policy;
    }
    static {
    route 0.0.0.0/0 next-hop pp0.0;
    }

    I don’t understand why it does not work ? Also, for testing purpose, I’ve tried
    user@host# show routing-options
    forwarding-table {
    export load-balancing-policy;
    }
    static {
    route 0.0.0.0/0 next-hop pp0.0;
    route 8.8.8.8/32 next-hop 88.188.0.254
    }
    Then my internet access use ISP1, and when I want to access 8.8.8.8 I use ISP2.

    Any help please ?



  • This particular feature is supported from Junos 12.1

    You can check the below kb
    http://kb.juniper.net/InfoCenter/index?page=content&id=KB23417

    Let me know if you need any clarifications


 

30
Online

38.4k
Users

12.7k
Topics

44.5k
Posts