Help: LAG creation error: xSTP configuration disallowed on interface



  • All,

    I’m experiencing a error when creating LAG between two core switches (ex4600s).  This link is meant to be the 40g connection that I want traffic to pass through first when going rack to rack.  These core switches are setup in a new rack that will be expanding out our existing environment.
    However, I am running into an error and ‘the google’ was not helping to much.

    Juniper ex4600 switches (two of them)

    set chassis aggregated-devices ethernet device-count 1
    set interfaces ae0 aggregated-ether-options minimum-links 1
    set interfaces ae0 aggregated-ether-options link-speed 40g
    set interfaces et-0/0/24 ether-options 802.3ad ae0
    set interfaces et-0/0/25 ether-options 802.3ad ae0
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members all
    commit

    error: xSTP configuration disallowed on interface et-0/0/24 as it is part of an aggregate bundle
    error: configuration check-out failed

    Note: Also planning on using LACP, but the error persisted even without it.

    This will continue on interface et-0/0/25 if I remove et-0/0/24. This happens on both ends of the core switches.

    Anyone know the cause of this issue? Or the solution?



  • I am having the same issue trying to build the LAG between my VC (2x EX4600s) and my Dell SonicWALL NSA5600.  Any movement on this?

    Steps taken:

    [edit chassis]

    set aggregated-devices ethernet device-count 1

    [edit interfaces]

    set ae0 aggregated-ether-options minimum-links 2

    set ae0 aggregated-ether-options link-speed 10g

    delete interfaces xe-0/0/0 unit 0
    delete interfaces xe-0/0/1 unit 0
    delete interfaces xe-1/0/0 unit 0
    delete interfaces xe-1/0/1 unit 0

    set xe-0/0/0 ether-options 802.3ad ae0
    set xe-0/0/1 ether-options 802.3ad ae0
    set xe-1/0/0 ether-options 802.3ad ae0
    set xe-1/0/1 ether-options 802.3ad ae0

    set interfaces ae0 aggregated-ether-options lacp active

    set interfaces ae0 unit 0 family ethernet-switching port-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members all

    set ae0 unit X family inet address x.x.x.x/x

    Thanks,

    -Phil



  • Phil,

    Yes! I spent some time on the phone with juniper support and the fix is very easy.

    The error is due to the xstp protocol (in my case rstp) being set on the two interfaces I was trying to aggregate.  It needs to be removed from them and placed on the aggregated interface (ae0 for me)

    delete protocols rstp interface et-0/0/24
    delete protocols rstp interface et-0/0/25
    set protocols rstp interface ae0

    Thanks,
    Josh


 

4
Online

38.4k
Users

12.7k
Topics

44.5k
Posts