Unable to connect to the IRE Cryptographic Service Provider



  • Hi,

    i was using NetScreen-Remote v8.2r1 at work and upgraded to v8.5 recently,
    however, the installation failed with blue screen when it reboots.
    it was saying something wrong with Crypto.sys.
    then i uninstall the v8.5 and reinsall v8.2r1.

    but now even v8.2r1 is not properly working either.
    as i click to open Certificate Manager, i get an error message below:

    “Unable to connect to the IRE Cryptographic Service Provider.
    This component may not be properly installed. Please repair or reinstall NetScreen-Remote.
    The specific error was: 80090006 during CryptAcquireContext.”

    so i repair and reinstall but still get the same error massage.
    i tried to restore Windows XP but it failed as well…
    has anyone got any idea, how i can solve this situation?

    environment:
    Windows XP SP2
    Soliton SmartOn Client
    Symantec Antivirus
    Netscreen-Remote v8.2r1
    Netscreen-Remote v8.5

    Best Regards,
    uzrk



  • Solved…

    Uninstalled Netscreen Remote completely.

    Went through the registry, deleting all mention of IRE Cryptographic services (AFTER backing it up), renamed all the files mentioned by registry in relation to IRE to OLD.

    Rebooted.

    Reinstalled Netscreen…

    And there we go.



  • Having EXACTLY the same problem - I’ve uninstalled the software several times, latest install is 8.7 of Netscreen Remote - same issue, have just gone through the registry deleting all reference to IRE, and am about to reinstall…
    again…


 

23
Online

38.4k
Users

12.7k
Topics

44.5k
Posts