Network Connect driver installation failed. (

  • still seeing this error….BUMP…anyone?

  • in some cases you have to uninstall NC, remove all NC folders from the (multiple) userprofiles from that clientmachine and sometimes you even have to remove that network connect adapter under: “device manager” > view > show hidden devices. then look for network devices and remove/uninstall “juniper network connect virtual adapter”.

    then reinstall and it should work. but isnt really a solution if thousand users have this problem…

  • Ran into this today after we updated our IVE from 6.3 to 6.5, we had a few users call in getting this same error when trying to update.  I hadn’t ran into that in the testing with 5 PC’s I did before I updated the main IVE so not sure why some people are getting it.  I found just a bit ago when working on one of them that I got it to work by downloading the installer package from the admin page to that user’s desktop.  Then I uninstalled the existing Juniper Network Connect software from Add/Remove Programs, then ran that installer package I put on his desktop to install it manually then he was able to login successfully so that appeared to do the trick.

  • BUMP! Any resolution to this?

  • Hi, I am still getting this error.  XP SP3, I have tried everything in this formum and still the file fails.  I tried installing another xp admin account and that did not work.  I tried the regedit32 and did not have a security folder to change.

  • Actually if this is is in Vista x64 you need to make sure all signs of Juniper are removed. Run uninstaller from programs and settings, delete the Juniper folder from Program files folder and delete Juniper folder from your user account Usename>appdata>roaming folder.
    Re run installer and that should work.

  • It appears that a Microsoft Security Patch is causing this issue.  In my case recreating the Windows profile appeared to fix the issue.

  • had the same problem with the xp machine of a user; couldn’t find the reason but could fix it by creating another xp admin account, logged in onto this account, installed the juniper driver onto this user account  :mrgreen:

  • Here is what I found on. On the particular machine, when I went to the device manager, it was blank. I used this site as a reference to fix that problem

    I then was able to install the NC client on the machine.

    It turns out that (i think it was a windows security update that did it) the permissions to a folder in the registry were removed.

    I hope this helps!

  • I am having the same issue on 1 client as well. Any info would be appreciated. I have tried uninstalling etc still with the same error.