Network Connect breaks on OSX 10.5 Leopard


  • administrators

    Fails while unpacking with the following error:

    Dyld Error Message:
    Library not loaded: /usr/lib/libcrypto.0.9.dylib
    Referenced from: /usr/local/juniper/nc/install/ncinstallhelper
    Reason: no suitable image found. Did find:
    /usr/lib/libcrypto.0.9.dylib: mach-o, but wrong architecture
    

    The files are obviously different between the two versions (as an MD5 sum confirms).  However, both show up as the same type of file:

    bohr:/usr/lib root# file libcrypto.0.9.dylib 
    libcrypto.0.9.dylib: Mach-O dynamically linked shared library ppc
    
    

    I’m on an Intel based box, so just ignore the fact that it says PPC above.  Has anyone else noticed this issue?  I have the same behavior in Firefox and Safari.



  • Thanks for the info .  I meant for the University except for emergencies for computers on campus.
    I will try to contact them.



  • Jay, you need to speak to you admin to get him to upgrade.

    Also, support is 24/7/365, I spoke to them today myself.



  • I am an end user and I am not able to get to my university network connect with Leopard os x 10.5.  The link on the vpn site refuses to work and I can’t find a way to download the required upgrade i gues it is  6.0R2?  Support is off for the holidays and I need to vpn to get access to the library.
    thanks



  • We had the same problems with 5.5.  Juniper told us to upgrade to 6.0R2.  Things seem to be working just fine with that version.


  • administrators

    @dark_15:

    Have you tried reinstalling Java?  I believe the system uses a Java component in order to launch the application.

    Java works just fine with other stuff.  I don’t really care if I cannot launch it through the web interface or not right now.  A permanent fix will come along soon.



  • Have you tried reinstalling Java?  I believe the system uses a Java component in order to launch the application.


  • administrators

    Ok, works with the standalone installer, but only if I launch Network Connect through the Applications menu.  If I try to launch through the browser, it fails.


  • administrators

    I’m on 5.5.0.  I don’t have access to the admin page to download the standalone installer.  I’m trying to get it now from one of the admins.



  • @signal15:

    I did this yesterday, but I still am having problems installing the client.  I get an “Installation Failed” error when it runs the installer.  There is no debugging output from it at all, so it’s difficult to see where it’s failing.

    I do not get the libcrypto and libssl errors anymore though.

    What about downloading the installer from the admin side and running it from there?  What version of the IVE OS are you running?


  • administrators

    I did this yesterday, but I still am having problems installing the client.  I get an “Installation Failed” error when it runs the installer.  There is no debugging output from it at all, so it’s difficult to see where it’s failing.

    I do not get the libcrypto and libssl errors anymore though.



  • Yes our company has run into this, but we were able to find a workaround:

    In the console type:

    
    cd /usr/lib
    sudo cp libcrypto.0.9.dylib libcrypto.0.9.dylib.old
    sudo cp libssl.0.9.dylib libssl.0.9.dylib.old
    sudo rm libssl.0.9.dylib
    sudo rm libcrypto.0.9.dylib
    sudo ln -s libcrypto.0.9.7.dylib libcrypto.0.9.dylib
    sudo ln -s libssl.0.9.7.dylib libssl.0.9.dylib
    
    

    And NC should work again.  It looks like NC is using an old version of the libcrypto file, but by renaming it NC starts to use the updated (and working) file.  We’re using IVE OS 5.5R3, so YMMV on other versions of the OS.


 

43
Online

38.4k
Users

12.7k
Topics

44.5k
Posts