Firefox 2.0.0.10 doesn't work with the IVE



  • Just a heads up.

    When you try to login you get a blank white page.  TAC knows about this and is working on something, but right now 2.0.0.10 is not supported and you’ll be asked to use 2.0.0.9 or older.



  • Just a note for all you having the same problem with LDAP. It isn’t a bug on R3.1, but it’s a bug since R3. For a workaround you should disable “Password management” for openLDAP-Services.

    Can somebody post this in the regarding Juniper Support Forum (the link above), because I don’t have a account there.

    Thanks.

    Regards,
    Dennis





  • @spacyfreak:

    Do a  Policy Trace to find out where it seems to “hang”.

    I did that. The Policy Trace says something like

    “Sign-in rejected using auth server Webmail2 (LDAP Server).  Reason: OK”

    Nice reason, eh?

    I’ve downgraded to R3, but that sadly didn’t solve the problem. So perhaps, it isn’t really a R3.1-bug. I’ve opened a case for this. Just be careful.

    Regards,
    Dennis



  • Do a  Policy Trace to find out where it seems to “hang”.



  • Hi!

    Just a quick note to all of you, that R3.1 is out, but introduces a new bug (as it seems). After installing, the IVE connected to our LDAP-Server and the LDAP-Server returned no error, but the IVE still didn’t allow the user to login.

    So be careful when trying R3.1 out.

    Regards,
    Dennis



  • SolutionThese versions of Firefox are not supported at this time.  Juniper is working on this issue and will update this KB Article as developments come.  For now, please rollback to the previous version of Firefox (2.0.0.9 or older).

    The problem was introduced by a security fix in Firefox 2.0.0.10.  Details of that security fix is at http://www.mozilla.org/security/announce/2007/mfsa2007-37.html
    We (Juniper) modified  our product to be compatible with these changes.  The modifications will be available in our Maintenance Releases 6.0R3.1 (12/31/07 ETA) and 5.5R5 (12/27/07 ETA).



  • Looks like this is going to be fixed in 6.0R3.1 and 5.5R5.



  • After you get this blank page then go to the original page you logged into (like ssl.company.com).You should get your home page that you would have gotten before the upgrade.
    Or simply downgrade to Firefox 2.0.09
    http://releases.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.9/win32/en-US/

    It’s unclear if this is a Juniper or Firefox bug.



  • http://kb.juniper.net/CUSTOMERSERVICE/index?page=kbdetail&article_id=KB10455

    Yo Firefox 2.0.0.10 or higher is at this time NOT supported by Juniper Secure Access!



  • @alan:

    If you return to your login page it will not be the usual login/password one but your typical home page. Then (assuming it’s enabled which I believe is the default) in the upper right you will see a “Client Apps” box (Home, Client Apps, Preferences,Help, Signout). Click Client Apps then click “Start”. This works for me for Network Connect. NC doesn’t start even though is  set to auto-launch.

    I know this box “Client Apps” - but after i login to my ive.company.com, i DONT SEE THIS BUTTON! I only see a WHITE, BLANK website, and NOTHING ELSE!

    Anyway - i will have to inform my customers not to upgrade to ff 2.0.0.10 or higher, and i hope that juniper will react as soon as possible to bring out a fix. I dont believe that mozilla will react because of a handfull of users who use ff to connect to Juniper IVE System. They have millions of other users whose needs are much more interesting to mozilla.
    Damn - it sucks that IVE is so much depending on webbrowser compatibility.



  • Everyone: get over to the Mozilla Bug track, create an account (really easy), and vote on the following BugID:

    https://bugzilla.mozilla.org/show_bug.cgi?id=406171
    Or search on “Juniper SSL”

    Mozilla responds to bugs that are “hot” as voted on in Bugzilla tracking. Right now there’s only 2 votes of this FF 2.0.0.10/11 bug.



  • If you return to your login page it will not be the usual login/password one but your typical home page. Then (assuming it’s enabled which I believe is the default) in the upper right you will see a “Client Apps” box (Home, Client Apps, Preferences,Help, Signout). Click Client Apps then click “Start”. This works for me for Network Connect. NC doesn’t start even though is  set to auto-launch.



  • I dont understand your workaround, alan.
    I installed FF 2.0.0.11 and i dont see ANYTHING.
    Just a blank, white site, and obove i read “Please wait…”.
    Hostchecker Precheck is successfull, and i can login to ive.company.com, but then NOTHING happens after i logged in successfully.
    Just this “Please wait…” message. But the Site remains BLANK.



  • same here with 5.5R2 and Fireforx 2.0.0.11
    workaround - click on link to login page (ssl.company.com), then client apps, then “start”



  • Thats right - i tried it out now and you only get a white website, though hostchecker and login works. I run IVE OS 6.0R2.


 

32
Online

38.4k
Users

12.7k
Topics

44.5k
Posts