OSPF on a NS25



  • Hi,

    We have a NS25 with two ISP connections. Originally we had only one, and it is bound to the OSPF area as directed by our ISP. No issues, routes are there, yadda yadda. We have added a 2nd wireless radio, and are trying to configure it as a hot-backup. The interface is bound to the same area, adjacencies are formed with the ISP router, but no routes are being added for that interface. I would expect another set of routes to be added (though with a higher cost as we set that on the interface).

    Any thoughts or comments are appreciated.

    -Travis



  • @MaxPipeline:

    Only the best route will be added to the routing table. The only way to see both routes is to have both routes be equal cost and ECMP enabled. But that would imply that both routes are active. With OSPF you should only see the best route in the table. Have you tested the route failover by dropping the link to your primary connection?

    I will be testing this over the holidays and post the results. Thanks for the reply - that is what I was thinking but could not find confirmation (even from our consultant).

    -Travis



  • Only the best route will be added to the routing table. The only way to see both routes is to have both routes be equal cost and ECMP enabled. But that would imply that both routes are active. With OSPF you should only see the best route in the table. Have you tested the route failover by dropping the link to your primary connection?



  • Hello,

    I should have clarified, it is one ISP, we just added a second radio that points to a different tower of theirs. Their consultant beleives there won’t be any ‘extra’ routes added to the route table, and that if our primary radio goes down we will still have the connection thru the new link. I would have expected two sets of routes (one for each WAN interface). I am going to test bringing down the primary interface in the next week or two to see ‘what happens’. (Off-hours of course).

    The basic OSPF config is as follows:

    set vrouter "trust-vr"
    set router-id "LOOPBACK IP"
    set access-list 1
    set access-list 1 permit ip x.x.x.x /xx 1
    set access-list 1 permit ip x.x.x.x /xx 2
    set route-map name “Outbound” permit 1
    set match ip 1
    exit
    unset add-default-route
    set protocol ospf
    set redistribute route-map “Outbound” protocol connected
    exit
    exit
    set interface ethernet2 protocol ospf area 0.0.0.x
    set interface ethernet2 protocol ospf enable
    set interface ethernet2 protocol ospf cost 1
    set interface ethernet4 protocol ospf area 0.0.0.x
    set interface ethernet4 protocol ospf enable
    set interface ethernet4 protocol ospf cost 100
    set vrouter "untrust-vr"
    exit
    set vrouter “trust-vr”

    -Travis


  • Global Moderator

    Two ISP’s and the same area? Then the two ISP’s should also connect to eachother! OSPF with your ISP is very unusual anyway. When running dynamic routing with a ISP one would go for BGP normaly in my humble opinion.



  • Can you post the config perhaps?


 

31
Online

38.4k
Users

12.7k
Topics

44.5k
Posts