Netscreen 5gt halo server



  • Finally got my netscreen box up and running and wanted to publish my halo server to the web. I have tried to set up a VIP with a custom service, but with no avail. here is my setup, any help would be appreciated.

    set clock ntp
    set clock timezone -5
    set vrouter trust-vr sharable
    set vrouter "untrust-vr"
    exit
    set vrouter "trust-vr"
    unset auto-route-export
    exit
    set service “Halo Server” protocol tcp src-port 2300-2305 dst-port 2300-2305
    set service “Halo Server” + udp src-port 2300-2305 dst-port 2300-2305
    set service “Halo Server” timeout never
    set auth-server “Local” id 0
    set auth-server “Local” server-name "Local"
    set auth default auth server "Local"
    set auth radius accounting port 1646
    set admin name ""
    set admin password ""
    set admin auth timeout 10
    set admin auth server "Local"
    set admin format dos
    set vip multi-port
    set zone “Trust” vrouter "trust-vr"
    set zone “Untrust” vrouter "trust-vr"
    set zone “Wzone1” vrouter "trust-vr"
    set zone “VLAN” vrouter "trust-vr"
    set zone “Untrust-Tun” vrouter "trust-vr"
    set zone “Trust” tcp-rst
    set zone “Untrust” block
    unset zone “Untrust” tcp-rst
    set zone “MGT” block
    set zone “Wzone1” tcp-rst
    set zone “VLAN” block
    set zone “VLAN” tcp-rst
    set zone “Trust” screen alarm-without-drop
    set zone “Trust” screen icmp-flood
    set zone “Trust” screen winnuke
    set zone “Trust” screen port-scan
    set zone “Trust” screen tear-drop
    set zone “Trust” screen ip-spoofing
    set zone “Trust” screen ping-death
    set zone “Untrust” screen alarm-without-drop
    set zone “Untrust” screen icmp-flood
    set zone “Untrust” screen winnuke
    set zone “Untrust” screen port-scan
    set zone “Untrust” screen tear-drop
    unset zone “Untrust” screen syn-flood
    set zone “Untrust” screen ip-spoofing
    set zone “Untrust” screen ping-death
    unset zone “Untrust” screen ip-filter-src
    unset zone “Untrust” screen land
    set zone “Untrust” screen icmp-large
    set zone “V1-Untrust” screen tear-drop
    set zone “V1-Untrust” screen syn-flood
    set zone “V1-Untrust” screen ping-death
    set zone “V1-Untrust” screen ip-filter-src
    set zone “V1-Untrust” screen land
    set interface adsl1 phy annex-b-mode non-dt
    set interface “trust” zone "Trust"
    set interface “wireless1” zone "Wzone1"
    set interface “wireless2” zone "Trust"
    set interface “untrust” zone "Untrust"
    set interface “adsl1” pvc 8 35 mux llc protocol bridged zone "Null"
    unset interface vlan1 ip
    set interface trust ip 192.168.254.254/24
    set interface trust nat
    set interface wireless2 ip 192.168.253.254/24
    set interface wireless2 nat
    set interface untrust ip 68.221.7.106/32
    set interface untrust route
    unset interface vlan1 bypass-others-ipsec
    unset interface vlan1 bypass-non-ip
    set interface trust ip manageable
    set interface wireless2 ip manageable
    unset interface untrust ip manageable
    set interface untrust vip untrust 2300 “Halo Server” 192.168.254.1
    set interface wireless2 dhcp server service
    set interface wireless2 dhcp server enable
    set interface wireless2 dhcp server option lease 5760
    set interface wireless2 dhcp server option gateway 192.168.253.254
    set interface wireless2 dhcp server option netmask 255.255.255.0
    set interface wireless2 dhcp server option domainname Wireless.joshnet.home
    set interface wireless2 dhcp server option dns1 205.152.37.23
    set interface wireless2 dhcp server option dns2 205.152.132.23
    set interface wireless2 dhcp server option dns3 205.152.37.23
    set interface wireless2 dhcp server option smtp 207.115.11.17
    set interface wireless2 dhcp server ip 192.168.253.3 to 192.168.253.10
    unset interface wireless2 dhcp server config next-server-ip
    set interface wireless1 shutdown
    set flow tcp-mss 1392
    set flow all-tcp-mss 1304
    unset flow tcp-syn-check
    set hostname Rex5GT
    set failover enable
    set pki authority default scep mode "auto"
    set pki x509 default cert-path partial
    set dns host dns1 192.168.254.1 src-interface trust
    set dns host dns2 205.152.37.23
    set dns host dns3 205.152.132.23 src-interface trust
    set dns ddns
    set address “Trust” “192.168.254.1/24” 192.168.254.1 255.255.255.0
    set address “Trust” “192.168.254.155/24” 192.168.254.155 255.255.255.0
    set ippool “Global” 192.168.250.1 192.168.250.5
    set user “dutchmaster” uid 1
    set user “dutchmaster” ike-id u-fqdn “” share-limit 1
    set user “dutchmaster” type  ike l2tp
    set user “dutchmaster” remote dns1 "192.168.254.1"
    set user “dutchmaster” remote dns2 "205.152.132.23"
    set user “dutchmaster” password ""
    unset user “dutchmaster” type auth
    set user “dutchmaster” "enable"
    set user-group “VPNgroup1” id 1
    set user-group “VPNgroup1” user "dutchmaster"
    set ike gateway “VPN Gateway” dialup “VPNgroup1” Aggr outgoing-interface “untrust”

    preshare “” proposal ""
    unset ike gateway “VPN Gateway” nat-traversal
    set ike respond-bad-spi 1
    unset ike ikeid-enumeration
    unset ike dos-protection
    unset ipsec access-session enable
    set ipsec access-session maximum 5000
    set ipsec access-session upper-threshold 0
    set ipsec access-session lower-threshold 0
    set ipsec access-session dead-p2-sa-timeout 0
    unset ipsec access-session log-error
    unset ipsec access-session info-exch-connected
    unset ipsec access-session use-error-log
    set vpn “JoshNet VPN” gateway “VPN Gateway” no-replay transport idletime 0 proposal

    “”  “”  “”  ""
    set l2tp default dns1 192.168.254.1
    set l2tp default dns2 205.152.132.23
    set l2tp default ippool "Global"
    set l2tp default ppp-auth chap
    set l2tp “JoshNet VPN” id 1 outgoing-interface untrust keepalive 60
    set url protocol websense
    exit
    set policy id 3 from “Trust” to “Untrust”  “192.168.254.1/24” “VIP(untrust)” "Halo

    Server" nat src permit log count
    set policy id 3
    exit
    set policy id 2 from “Untrust” to “Trust”  “Dial-Up VPN” “Any” “ANY” tunnel vpn

    “JoshNet VPN” id 1 l2tp “JoshNet VPN” log
    set policy id 2 disable
    set policy id 2
    set log session-init
    exit
    set policy id 1 from “Trust” to “Untrust”  “Any” “Any” “ANY” permit
    set policy id 1
    exit
    set pppoe name "untrust"
    set pppoe name “untrust” username “” password ""
    set pppoe name “untrust” idle 0
    set pppoe name “untrust” interface untrust
    set pppoe name “untrust” auto-connect 5
    set nsmgmt bulkcli reboot-timeout 60
    set ssh version v2
    set config lock timeout 5
    set ntp server "us.pool.ntp.org"
    set ntp server src-interface "untrust"
    set ntp server backup1 "ca.pool.ntp.org"
    set ntp server backup2 "time.windows.com"
    set modem speed 115200
    set modem retry 3
    set modem interval 10
    set modem idle-time 10
    set wlan channel auto
    set wlan advanced cts-type cts-rts
    set ssid name Rex5GT
    set ssid Rex5GT authentication wpa-psk passphrase
    = encryption tkip
    set ssid Rex5GT interface wireless2
    set snmp port listen 161
    set snmp port trap 162
    set vrouter "untrust-vr"
    exit
    set vrouter "trust-vr"
    unset add-default-route
    set route 192.168.253.0/24 interface trust gateway 192.168.254.150 preference 20

    permanent
    set route 192.168.253.0/24 interface wireless2 gateway 192.168.254.150 preference 20

    permanent
    exit
    set vrouter "untrust-vr"
    exit
    set vrouter "trust-vr"
    exit



  • Your problem is likely with your Halo Server service:

    set service “Halo Server” protocol tcp src-port 2300-2305 dst-port 2300-2305
    set service “Halo Server” + udp src-port 2300-2305 dst-port 2300-2305
    set service “Halo Server” timeout never

    The problem I see is you are limiting the source port to be only 2300-2305 which is unlikely to work since most users are behind a NAT device and will use a random source port. Try changing the src-port to 0-65535. Dst-port seems to be OK.

    Also your VIP policy is from trust to untrust. It should be the other way around. Try changing the policy as below:

    set policy top from “Untrust” to “Trust”  “Any” “VIP(untrust)” “Halo Server” permit


 

38
Online

38.4k
Users

12.7k
Topics

44.5k
Posts