OSPF Database Observation



  • Hello all. I have been looking at the topology of the OSPF network that I am currently working with.

    When I do a show ip ospf database there is one subnet that is not
    appearing in the “Net Link States (Area 0)” ….even though it is a LAN and it is in area 0.

    Now the only thing I can think of is that there is only one OSPF
    router on this segment, which is obviously the DR, so could this
    be why it is not advising us of this network. (the network statement does cover this interface)

    Any clues appreciated.

    Rgds Simon



  • My guess is there is nothing running OSPF connected on the interface (or blocked by ACL), or the other side does not have the proper network statements or area.  You should have a router-id statement in your OSPF config , usually the loopback address.  I would also use MD5 password authentication.

    Greg


  • Global Moderator

    Don’t know much about cisco’s, sorry!



  • And here is a bit of the config……

    interface FastEthernet1/1
    description link to xyz
    ip address 10.146.160.3 255.255.255.0
    ip helper-address 10.128.161.68
    speed 100
    full-duplex
    standby 1 ip 10.146.160.1
    standby 1 priority 110
    standby 1 preempt
    standby 1 track FastEthernet1/0 50
    !         
    router ospf 100
    log-adjacency-changes
    redistribute connected subnets
    redistribute static subnets
    network 10.128.169.128 0.0.0.3 area 0
    network 10.146.136.1 0.0.0.0 area 0
    network 10.146.160.0 0.0.0.255 area 0
    !



  • Hi there….just a box standard router. It is the only ospf router on the segment that is not being included in the ospf database.

    Cisco Internetwork Operating System Software
    IOS ™ 3600 Software (C3640-DS-M), Version 12.2(29a), RELEASE SOFTWARE (fc1)
    Copyright © 1986-2005 by cisco Systems, Inc.
    Compiled Fri 12-Aug-05 16:50 by tinhuang
    Image text-base: 0x60008930, data-base: 0x61264000

    ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)


  • Global Moderator

    Hi Simon,

    what kind of device are you talking abour here?



  • Hi thanks for replying. Yes the network statement covers
    the lan interface, though there is no specific interface configuration on the router for that interface, and I don’t think there needs to be.

    Thanks


  • Global Moderator

    Did you enable OSPF on interface level?


 

37
Online

38.4k
Users

12.7k
Topics

44.5k
Posts