ERX - BRAS DHCP



  • Hi, We are running ERX-310 as BRAS.

    We have separate Radius Server and using ERX local DHCP server for IP Pool to provide IPs for PPPoE clients.

    Now we are planning to introduce Prepaid Broadband solution.
    For that we have already running HotSpot ( WiFi Gateway) with Captive Portal and separate Radius Server.

    Now we need two different PPPoE clients solution

    Solution 1 = PPPoE user will authenticate with Radius and get Public IP address from BRAS. (this is currently working)

    New Plan.
    Solution 2 =  when PPPoE connect with user free= pass= free, Radius will authenticate and then let BRAS know to provide IP address from IP Pool “HotSpot” (its should be redirect to WiFi Gateway (DHCP) to get IP address and assign to client ADSL modem with given below info
    ADSL modem = IP address: 192.168.200.201 Mask 255.255.255.0 GW: 192.168.200.1

    So this modem traffic should pass through BRAS to WiFi Gateway, BRAS should work as Bridge mode.

    Soon this client try to access internet from browser Captive Portal page display to enter username / password then client need to enter username/pass from there scratch card.

    Current running configuraiton
    virtual-router default
    virtual-router NOC  <–--------Currently we are using this

    virtual-router default

    radius authentication server 55.x.x.x
    udp-port 1645
    retransmit 2
    key abcd123
    !
    radius accounting server 55.x.x.x
    udp-port 1646
    key ACSIPDEV
    !
    radius update-source-addr 55.x.x.x
    radius acct-session-id-format decimal
    radius vlan nas-port-format stacked

    virtual-router NOC
    aaa authentication atm1483 default radius
    aaa accounting atm1483 default radius
    aaa authentication ip default radius
    aaa accounting ip default radius
    aaa authentication ipsec default radius
    aaa accounting ipsec default radius
    aaa authentication ppp default radius
    aaa accounting ppp default radius
    !
    ip address-pool local
    aaa authentication radius-relay default radius
    aaa accounting radius-relay default radius
    aaa authentication tunnel default radius
    aaa accounting tunnel default radius
    !
    ip domain-lookup
    ip name-server 202.x.x.x
    ip name-server 203.x.x.x
    !
    interface null 0
    interface loopback 0
    ip address 55.x.x.x 255.255.255.255
    !
    interface gigabitEthernet 1/0
    ethernet description "Link to Cisco 4507 port 1/3"
    ip address 55.x.x.x 255.255.255.248

    interface gigabitEthernet 1/3
    ethernet description "DSLAM - access port"
    mtu 2000
    load-interval 30
    qos-profile "eth-def"
    svlan 11 qos-profile svlan
    svlan 12 qos-profile svlan
    svlan 13 qos-profile svlan

    interface gigabitEthernet 1/3.150001
    qos-profile "1M"
    svlan id 150 1
    svlan ethertype 8100
    !
    interface gigabitEthernet 1/3.344000
    qos-profile "1M"
    vlan id 344
    !
    interface gigabitEthernet 1/3.346000
    qos-profile "12M"
    vlan id 346

    ip route 0.0.0.0 0.0.0.0 55.x.x.x

    ip local pool "NOC-1Mb"
    ip local pool “NOC-1MB” 55.x.x.x 55.x.x.x

    What i think, to do this we need to create new Virtual Router.
    but i need sample configuration how to configure it, as i’m new to ERX. can please any one help me out how to solve this issue by sharing configuration.

    Thanks in Advance

    my email address : window911@yahoo.com


 

35
Online

38.4k
Users

12.7k
Topics

44.5k
Posts