RDP, Web, etc Quit Working After Disconnecting



  • Not sure if this is the right forum for this or not, but I’ve developed an odd problem with my home PC running Windows 7.  If I connect to our SSL VPN to work from home then disconnect, then later from work I’ll try to RDP into my home PC from work and it won’t connect.  I also find that my VNC server won’t connect and my web server that’s running on my home PC also isn’t working.  I know my home PC is online because I see I’m signed into Windows Live Messenger and IRC so it’s as if something is goofed up with my IP stack on my home PC.

    This issue would make sense if I had remained connected then my IP would be the one given out by our SSL VPN box but I’m disconnected so that’s not the case.  This is the 2nd time in a row this has happened and we have not changed anything on our SSL VPN box at all, no new IVE software or config changes so likely the issue is on my home PC.  If I reboot my home PC then I can RDP into it from work, web server works, etc again until I reconnect/disconnect to the VPN.  I don’t understand this at all as I’ve done this many many times and never ran into this before.  Ideas?



  • Some of these I’ll have to check later but I know we aren’t using split tunneling.  I CAN ping my PC internally and the outside IP when this issue is happening.  We are using Juniper Network Connect, now we are on 6.5R3.1 which we just upgraded to from 6.3 this week and it didn’t make a difference.

    I’ll have to check on the route print later maybe this weekend.



  • ah now i understand…

    sounds like it changes your routing tables, are you using split tunneling at your ssl vpn box? if not, try configuring split tunneling only for test purposes and check if its still unavailable from outside after disconnecting from the ive!

    what says a “route print” on your home computer before, while, and after being connected? is the output after disconnecting the same as before connecting? (cause while being connected it surely adds some routes).

    can you ping your computer from:
    a) outside?
    b) home-lan?
    after disconnecting?

    are you using network connect? W/JSAM? or only SSL VPN over bookmarks?



  • My computer at home is in my router’s DMZ so it’s open to the internet.  So I CAN remote desktop into my home PC from anywhere.  However after connecting to the VPN from it then disconnecting, I can no longer remote into it from anywhere until I reboot it.  It’s almost as if it still is on the VPN but it’s not, I ran ipconfig /all and verified it definitely disconnected from the VPN.  But not only that I can’t even VNC into it, and also my web server quits being outside accessible.  I reboot and all these problems are fixed until the next time I do a VPN session.

    Nothing changed on our SSL VPN box to cause this so I’m assuming the issue is with my home PC but not sure what.  Yesterday while I was home sick I played with it a bit trying to figure it out.  I found I also couldn’t RDP to my home desktop from a laptop on the same home network, or VNC, or access the website, so it also affects the local network.  I tried an ipconfig /release /renew after and didn’t help, I also went through and reset almost every Windows service possible such as DNS, DHCP, workstation service, etc etc and nothing but a reboot would fix it.  Very puzzling.



  • i dont really understand what you mean.

    "I connect to our SSL VPN to work from home then disconnect, then later from work I’ll try to RDP into my home PC from work and it won’t connect."
    it cant work, if you disconnected before!? theres no vpn anymore. or i misunderstand sth here…



  • Anybody?  This is seriously troubling.  I’m sitting at home now and just connected then disconnected and tested my web server and it’s down just like I said.  I restarted it and no go.  I restarted almost every service that’s running and still didn’t fix it.  I also cannot remote desktop to my PC from a laptop on the same internal network.  If I reboot my desktop right now it will fix it again until next time I connect.  Again I’m on Win 7 64bit, and this problem just started a couple weeks ago and nothing has changed on the SSL VPN side.  My bro who is on my same network at home, connects to the same SSL VPN box and disconnects and does NOT have this problem and he too is on Windows 7 64bit.


 

33
Online

38.4k
Users

12.7k
Topics

44.5k
Posts